[XviD-devel] API 3.0 (more stuff)

Michael Militzer xvid-devel@xvid.org
Thu, 19 Sep 2002 22:21:11 +0200


Hi,

> What's missing in this prototype is qpel.

most likely I won't need any int options, some global flags should be
sufficient. I can think of the following:

XVID_QUARTERPEL                        /* use quarterpel ME/MC */
XVID_ADAPTIVE_QPEL                  /* allows XVID encoder to adaptively
switch between halfpel and qpel mode */
XVID_FAST_QPEL_REFINE            /* use reduced complexity quarterpel refine
*/

I'm not sure if the flag should be called XVID_FAST_QPEL_REFINE or better
PMV_FAST_QPEL_REFINE because normal halfpel refinement is also switched on
via the PMV_HALFPELREFINE[8,16] flag. On the other hand I wonder why this
flag has a PMV_ prefix at all. If I understood Christoph's explanation then
PMV_ flags should be PMVFast specific, but the halfpel switch has basically
nothing to do with PMVFast (or any other search algo), because the
refinement step is the same regardless which ME algo is chosen...

btw: we could add a similar flag for fast halfpel refinement:

XVID_FAST_HALFPEL_REFINE     /* use reduced complexity halfpel refine */

bye,
Michael