[XviD-devel] autoconf issues

Michael Militzer michael at xvid.org
Fri Feb 25 15:03:27 CET 2011

Quoting Fabian Greffrath <fabian at greffrath.com>:

>> And can you confirm that the patch to configure.in you propose is needed
>> only for newer autoconf versions? Because the pthread check in configure
>> actually seems to work fine here...
> I believe that more recent autoconf versions are stricter when it
> comes to parsing their input code, so yes, autoconf 2.59 may still be
> in use for configure.in files that are not yet adapted and checked for
> syntax errors. There is even a separate autoconf 2.59 package in
> Debian that I could try to run against configure.in, but whatever this
> leads to, the paragraph in configure.in that I pointed you to is
> faulty syntax anyway.

I've applied your configure.in patch to the 1.3 and HEAD branches. As
for the autoconf version: We'll make sure to use a newer one for the next


More information about the Xvid-devel mailing list